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2. Configuring the website 

2.1. Configuration options 

The Settings->Configuration options in the administration panel provides functionality to change the  
different options on  the front site. You may find below a list and description of the different  
configuration options.



Ads expire in (days)  
With this setting you can control the number of days in which the posted ads on the website will  
expire. The default value is 30, but you can easily change it with another number of days you prefer. 
If you set it to: -1 , then the ads posted on the website will never expire. 

Enable SEO URLs  
The search engines optimized urls look like static html pages and have keywords in the url (which  
allows better indexing by search engines like Google). 
In order to use the SEO links, the system will require the presence of the mod_rewrite module (for  
Linux / Apche or isapi_rewrite for Windows / IIS). If this module is not present on your server or  
hosting package, you could deactivate this feature by setting it to NO. 

Auto validate the new listings  
If set to NO, the listings posted on the front site will need to be validated from the administrator before  
they show up on the front site. The administrator can see and approve the new listings from the  
Dashboard page of Links Directory in the administration panel 

System Email Address  
You can set with it the system email address, which will appear as sender of the system emails sent  
by the website (like the email when the listings are approved etc.). 

  
System Email From Field 
The name of the sender of the system email address, which is used when sending email notifications,  
welcome emails and others to the users. 

Send email when approving listings  
If set to YES, an email will be sent to the user once his listing is approved by the administrator. With  
the settings below it's possible to set the email text and subject of the email message that will be sent. 

  
Approve email subject  
This setting allows to modify the subject of the email that will be sent to the user when his listing is  
approved. The default text is “Your listing has been approved!” and can be changed with whatever  
different text the administrator may prefer. 

  
Approve email text 
This setting allows to modify the subject of the email that will be sent to the user when his listing is  
approved. The default text is: 
“The listing you submitted 

{LINK} 

has been approved and added on our website.” 

in which {LINK} will be replaced with the url of the listing. 

Number of results per page  
By changing the value of this setting, you can control how many results will show up on the front site  
when the users make a search or browse the listings per make etc. 
The default value is set to 10. 

  
Number of category columns  



On the front page by default the categories show up in 3 columns – if you prefer another number like 4  
or 5 columns, you can easily set this by modifying the value of this setting. 

  
Number of listings in Featured section  
Use this setting to control the number of featured listings, which will show up in the Featured Listings  
section to the right. Please note that if there are featured listings on the website than the available  
positions (number you set in this field), then the featured listings will show up randomly in the Featured  
Listings section 

  
Message on successful new submission (free listings) 
This is the message the user will see when their listing (website) has been submitted successfully.  

Message on successful new submission (paid listings) 
Use this field and setting to modify the message that the users will see when submitting a paid listing.  
It's a separate and different message than the free listings, because often the administrator can  
choose to include information specific for the paid listings (for example – your listing will be approved  
as soon as we receive your payment). 

Website currency 
By default this setting is set to the US dollar sign “$”, but you may change it to another one you prefer  
(like CHF or ).  This will change the currency symbol displayed next to the prices on the website. 
This applies for all the prices of the listings on the website, pricing for posting listings and banners etc.  

  
Currency Code  
The PayPal currency code if the PayPal system is enabled. By default it's set to USD (US dollars), but  
can be changed to any other valid PayPal currency code like EUR, GBP etc. 

  
Use CAPTCHA images to prevent spamming  
A good way to avoid automatic form submissions when creating a web form is to add some kind of  
verification. One of the best ways is to use an image verification, called also captcha. What it does is  
to dynamically create an image with a random string displayed on it. Then visitor is asked to type that  
string in a text field and once the form is submitted it checks if the string on the image matches the  
one inputted by the user. 
The usage of the captcha images is enabled by default, but if you would like to disable it (for example  
if the PHP graphics library - GD isn't installed on your website), you could change the value of this  
setting to “NO”. 

  
Website time zone  
With this setting you can change the default time zone on the website. The time zone coming by  
default for most of the downloads is Europe/London. 
List of the supported time zones can be found on: http://www.php.net/manual/en/timezones.php

Some examples of supported time zones are: 

America/Buenos_Aires  
America/Chicago  
America/Los_Angeles  
America/Mexico_City  
America/New_York 
Asia/Singapore  
Asia/Tokyo 



Europe/Berlin  
Europe/Madrid  
Europe/Moscow  
Europe/Zurich  
… 

  
PAYMENT OPTIONS  NOTE  
ADS BOARD IS ONLY SET UP TO ACCEPT VIA COINPAYMENTS  
ALL OTHER PAYMENT METHODS IGNORE 

SEO text to be appended to the category page title  
When clicking on a category, the default page title will be the category name. By adding custom text in  
this field, you can customize the titles of the category pages, which will be then the Category Title +  
Your Text (so in this way you can create unique titles for better search engines optimization). 

  
SEO text to be appended to the category page meta description  
By adding a text in this field, you can add a text, which will be appended to the default meta  
description for SEO purposes.  

  
SEO text to be appended to the category meta keywords  
By adding a text in this field, you can add a text, which will be appended to the default meta keywords  
for SEO purposes.  

  
Website date format string  
By entering a valid PHP date format string, you can change the format of the date displayed on the  
website. 
Full information on the supported date format strings can be found on: 
http://www.php.net/manual/en/function.date.php 



Here are a few examples: 
"F j, Y, g:i a" // March 10, 2001, 5:16 pm 
"m.d.y" // 03.10.01 
"j, n, Y"  // 10, 3, 2001 
"H:i:s"  // 17:16:18 
  
Show number of listings in category 
If set to yes, will show the number of listings in each category on the front site. Keep set to NO, if you  
don't wish these numbers to show up. 

  

2.2. Setting the listing categories 

The software comes with a list with predefined categories, that can be easily modified from the Ads  
Management → Categories page in the administration panel. 

The new categories have to be entered as a list, one per line, with a starting number (it's not required  
that these are successive numbers). 

The script supports unlimited level of categories, the levels and hierarchy can be defined with the  
starting numbers, here is an example: 

1. Main Category 
1.1. Sub category of the main category 
1.2. Another sub category 
1.2.1. Sub sub category 
1.2.1.1. Level 4 category 
2. Another Main Category 
… 

Please note that on the front site the sub categories will be alphabetically sorted, so you may not sort  
them in the list and also you may not follow the order of the numbers – for example you can have 

1.1. First Category 
1.5. Second Category 
1.2. Third category 



In difference of the sub categories, the main – top level categories are not sorted, this can help the  
administrator to set the order in which he would like the main categories to show up.  

Modifying the locations works in exactly the same way as the categories – the new locations list has to  
be pasted as a list on the Locations page in the administration panel with starting numbers allowing to  
define the hierarchy (like explained above for the categories). 

2.4. Adding custom fields 

As administrator, you can add custom fields for selected categories from the Ads Management →  
Fields page in the administration panel.

This functionality can be useful to define specific fields for the different categories, for example Year,  
Color, Body Type for the Cars categories or Salary field for the Jobs category etc. 

To add a new field, it's necessary to first click on the category name and then enter the field name and  
possible values if the field is drop down select menu (if the possible values field in this form is left  
empty, then the new field that will be added will be a text field).

2.3. Setting the website pricing and packages 

The software allows to create different listing packages – free and paid that can differ on their price,  
and featured status (the featured listings show up with different background color, always on top of  
their categories and also randomly in the Featured Ads section to the right). 



The new packages can be added from the Ads Management → Packages page, by clicking on the  
Add a new package at the top of the page. 

When creating a new package, it's necessary to enter his name and description, price and if the  
package offers dofollow links, featured status or not.

The description shows up on the front site to the user and helps him select a package, so the  
administrator can explain with it the advantage of choosing a paid package (like for example that when  
the ad is featured it will have better exposure etc.). 
The field Active with possible values YES or NO allows to temporarily deactivate a package (for  
example if you temporarily don't wish to offer paid packages) or activate again after some time. 

3. Administration panel 

When creating the software, we tried to design the administration panel to be as easy to use and  
intuitive as possible and to allow fast and effective website management. The administration panel  
doesn't include only functionality for managing the listings and packages, but it includes also other  
features allowing to manage the website structure (add new pages, modify or remove the current  
ones), manage the site design / template and navigation menu, see statistics for the website visits,  
create custom server side forms or custom HTML tags and expand the existing functionality with your  
own php files and many others. 
The administration panel has Standard view (version optimized for computers and larger screens) –  
you may see it to the left and also Mobile view (optimized for mobile devices and small screens) – you  
can see it to the right. 



3.1. General overview 

The administration panel is the main tool available to the PHP Classified Ads administrator to manage  
the website, change its settings, templates and design, pages content etc. 

The features in the admin panel are divided in categories. The main administrator and the members of  
the Administrators group have access to all the categories and pages in them.  

The PHP Classified Ads administration panel functionality is divided in 8 categorie / menus in the main  
start menu:  

- Home (welcome / dashboard page, modification of password, log in report)  
- Ads Management (management of the listings, packages and options)  
- Website (front site structure and content management, navigation menu settings)  
- Extensions (custom extensions and extension files and different modules)  
- Templates (front site templates management)  
- Statistics (reports and referrals for the website visits)  
- Users (management of the administration panel users, groups and permissions)  
- Settings (management of the categories, regions, banner areas and others)  

3.2. Main pages in the administration panel 

You may find below a quick  
overview and brief information  
about the most used pages in  
the administration panel and  
functionality on it. 

Home → Welcome 



The Welcome page in the administration panel provides quick information about the new listings  
waiting to the approved and statistics, as well as links to the main pages in the administration panel for  
easier navigation.

Home → Log in Report 

The log in report shows a log of  
the administration panel log in  
attempts – the successful and  
failed log ins with their date and  
IP address.

Home → Change Password 

This page can be used to  
change the password of the  
user for the administration  
panel. To change the password  
it's necessary to enter the old  
password and the new one and  
confirm it – after the password  
is changed successfully, the  
user will be logged out and  
asked to log in again with his  
new password.



Ads Management → Dashboard 

The Dashboard page has links  
to   the   main   pages   for  
approving     the     links,  
configurations options, settings  
the  listing  packages  and  
categories.

Ads Management → Approve, Ads Management → Current Listings 

The Approve and Current  
Listings pages can be used to  
manage the new and existing  
listings   on   the   website,  
approve, delete or modify them.

Ads Management → Categories 

You can use the functionality on  
this page to manage the  
current categories and modify  
them. The  listing categories  
has to be set as a list, one  
category per link. Please check  
“Categories Management” in  
the   manual   for   more  
information about this. 

Ads Management → Packages 



As administrator you can can  
create different listing packages  
from this page – you can have  
free or paid listings, featured or  
standard and also set if the  
links from the website should  
be dofollow or nofollow links.

Ads Management → Locations 

The page can be used to  

modify the locations showing  
up on the front site (on the  
Browse by Location page and  
also on the page for submitting  
new ads).

Ads Management → Fields 

The functionality on the Fields  
page can be used by the  
administrator to add custom  
and specific fields for selected  
categories like Property Size  
for Properties, Salary for Jobs  
or Year, Color for Cars etc. 

Ads Management → Settings  



The page has many different  
options that you can use to  
configure your website in the  
way you prefer – set your  
timezone   and   currency,  
configure   the   preferred  
payment options and many  
others. Please find detailed  
description of the different  
settings in “2. Configuring the  
website”

Website → Management 

This is the main page to be  
used to manage the website  
structure and content – add  
new pages, remove or rename  
the current ones, modify the  
pages content, the page title  
meta   keywords   or   meta  
description or set custom php  
extension to be executed for a  
page.

Website → Navigation Menu 

Modifying the menu item template  
from this page can be useful when  
customizing the website look and  
feel or when integrating a custom  
design / front site template.



Website → Manage the forms 

The custom server side forms  
can be useful if you would like  
to create custom contact or  
feedback forms or any other  
type of forms to get information  
or inquiries from the users.  
When creating a new form you  
can add in it the fields you  
prefer – it's possible to create  
text fields and drop down  
menus by entering the possible  
values for them. 

The data sent by the users can be seen from the administration panel and / or to be forwarded to an  
email address set by the administrator (the email address and message that will be shown on  
successful form submission can be set when clicking on the Settings icon for a selected form). 

Website → Posted Data 

The page shows the data  
posted by the users from the  
custom server side forms (like  
the Contact form on the  
website). You can also choose  
this data to be forwarded to an  
email address you prefer, from  
the Settings page of the form. 

Extensions → Files 

The page shows the current files in  
the /extensions folder, which can  
be used for extensions of the  
pages or custom tags. Please note  
that files that should be used for  
custom tags have _tag at the end  
of their name. A file can be set to  
be executed as extension for a  
page from the Website →  
Management page and for a tag  
from Extensions → Tags 



Extensions → Tags 

You can use this page to see the  
current tags, delete any of them or  
add new tag. Please check the  
chapter “Custom Tags” to read  
more about their usage and  
functionality.

Extensions → News, Extensions → FAQ Manager, Extensions → Newsletter 

These   are   some   basic  
WebSiteAdmin modules loaded  
by default allowing to post  
news on the website, create a  
page with frequently asked  
questions and send newsletter  
to the users who have  
subscribed for it. 

Templates → Modify,  

Templates-> Select a  
Template, Templates → Add a  
New Template 

These pages can be used to  
modify the front site template,  
select a different template or  
add a new template by pasting  
its HTML code.  

For more information about the  
templates and their structure,  
please   check   the   section  



“Templates Management' in this manual. 

Statistics → Reports 

The   page   shows   brief  
information about the website  
visits and also displays a chart  
for them. 

Please note that the integrated  
website visits tracking and  
statistics information is basic  
and simple, for more advanced  
tracking and information, we  
recommend using an external  
system   such   as   Google  
Analytics, which can be easily  
added on the website. 

 

Statistics → Referrals 

You can see on this page the  
last referrals, so you can easily  
track who is linking to your  
website and from where the  
traffic to your website comes  
from.



Users → User Groups, Users → New User, Users → User Permissions 

Using these pages, you can add  
new administrator users to your  
website, put them in groups and  
set their permissions. This can  
be useful if you would like to  
have multiple users working on  
the website with permissions  
limited to just some selected  
pages. For example have a  
News Administrators group with  
permissions to access only the  
News Management functionality  
in the administration panel etc. 

Settings → Language Versions 

If you would like to run a multi  
language     website,     it's  
necessary to add the additional  
languages from this page in the  
administration panel. Please  
note when you a add a new  
language, it's necessary to  
upload also the language file for  
it in the /include folder on your  
website. Please refer to the  
“Languages and language files”  
for   more   information   and  
description of the language files  
and languages management. 

4. Listings Management 

In the latest version of the software, we tried to make the listings and packages as easy as possible –  
you may find below information about the main pages in the administration panel related to the listings  
approval and management. 



The Dashboard page provides quick links to manage and approve the links by package as well as  
create new listing packages and manage the different configuration options. 

4.1. Listing packages 

The software allows to create different listing packages – free and paid that can differ on their price  
and featured status (the featured listings show up with different background color, always on top of  
their categories and also randomly in the Featured Listings section to the right) or normal status.  

The new packages can be added from the Ads Management → Packages page, by clicking on the  
Add a new package at the top of the page. 

When creating a new package, it's necessary to enter his name and description, price and if the  
package offers featured status or not. 
The description shows up to the user and helps him select a package, so the administrator can explain  
with it the advantage of choosing a paid package. 
The field Active with possible values YES or NO allows to temporarily deactivate a package (for  
example if you temporarily don't wish to offer paid packages) or activate again after some time. 



4.2. Approving the ads 

The administrator can see the new listings to be approved on the Ads Management → Dashboard  
page and also directly on the home screen when he logs in – if there are new listings to be approved,  
a message like “There are 5 new ads waiting to be approved” will show up. 

The Dashboard page lists also the new listings to be approved per packages, this makes easier to  
manage for example the paid listings first and with priority and the free ones with lower priority.

To approve the new listings, please click on the Approve button on the Dashboard page or  
alternatively you may click on the package name for the package you would like to approve the new  
listings. The next page that will show up, will have the list of the listings waiting to be approved with  
the information about the listing, person who has posted it etc. 
It's easy to approve multiple listings at once – just click on the listing check box and the on the  
Approve button at the bottom. If you would to approve all the listings on the page, you can use also  
the Select All checkbox – click it and then click on Approve.

If you would like a listing inappropriate and would like to remove it, you can use click on the delete  
icon, which will delete the listing. 

There is also a Modify icon for every listing, allowing to modify the listing information before approving  
it. 



When approving the listings, if you have set on Settings → Configuration Options the value of “Send  
email when approving listings “ to YES, then an email will be sent to the user as soon as you  
approve the listing. 
Please note you can edit the subject and text of the email and set the text you prefer from the  
Configuration Options page (so you can include in this way information you think will be  
important to your users or advertisements). 

5. Website structure and content management 

The functionality, different menus and options on the Website → Management page allow the  
administrator to manage the website structure – add new pages, rename or remove the existing ones  
etc. and also manage the content of the website, edit the content of the different pages, set extensions  
to be executed for them and others.



5.1. Structure management, adding new pages 

Changing the front site pages meta title and description 

In order to change the front site pages meta title, keywords or description, the administrator has to log  
in in the admin panel and go to the Website->Management page.  
On this page, he will see the available website pages as a tree. He  has to left click with the mouse on  
a page in order to select it and then choose from the Context menu which will show up “Page  
Settings”.

A new page will show up containing various page fields including also the page meta title description.  
The administrator has to enter the new values and click Save. 

Adding new pages to the website 

The PHP Classified Ads admin panel offers  the possibility to freely edit the website structure – add,  
edit or delete the pages  of the front site. 



Please note that you need to define the website structure separately for the different language  
versions available (you could switch between the language versions by selecting the language from  
the big drop down menu at the top of the Website → Management page). 
In order to add a new page to the front site you need to click on the New Page button at the top of  
Website → Management

This will enter the form for adding a new page - 

with the following fields: 

- Link Text , the name of the link, which will show up in the main navigation menu 
- Page Type, it can be either a main page or a sub page of an already existing page 
- Title, the title of the page, which will show up in the title tag 
- Meta Description, the meta description of the page, which will appear in the meta description tag to  
be used for search engines optimization purposes 
- Meta Keywords, the meta keywords of the page, which have to be entered as a list and will appear  
after that in the meta keywords tag on the page, to be used for search engines optimization purposes 

Changing the pages hierarchy 

You can modify the front site pages hierarchy by clicking on the Change Hierarchy button at the top of  
Website → Management  using the form at the bottom of the Website->Management page.7 



This will open the change hierarchy form - this form there allows to make a page of the website either  
a main page or a sub page of an existing main page.

Changing the position of two pages 

By changing the position of 2 pages, you'll change the order of the pages in the main navigation menu  
(for example replace the positions of the Home and About us pages). 

Near every page on the Website->Management page, you could see 2  arrows indicating the up and  
bottom directions, you have to click on them in order to change the position of the pages.

Please note that you can change the position of 2 pages only if they are on the same level in the  
website hierarchy (for example main pages, or sub pages of the Home page etc.) 

5.2. Modifying the content of the pages 

The content of the pages can be modified from the Website->Management page in the admin panel.  
On this page, the administrator see the pages as a tree. 

If the website is multi language, you need to choose the language version to manage by using the  



drop down to the left on Website → Management - this will switch between management of the pages  
of the different language versions.  

Please note that if you would like to modify the content of a page and the website is multi language,  
you need to do this for every language. For example modify the “Contact” page in the English version,  
then the “Contacto” page in the Spanish version etc. 

To edit the content of a page like for example the Contact us page, the administrator has to click on it  
and then choose either “Launch WYSIWYG editor” or the “Edit HTML code” option. 

When using the Edit the HTML code option, you will be able to directly modify the html code of the  
page, while with the first (Edit the page), a WYSIWYG (what you see is what you get) editor will open,  
allowing to modify the content of the page.

Please note that the pages for which php files are set to be executed (the “Set Custom Extension”  
option) can't be modified directly with the WYSIWYG editor. These pages can be easily distinguished  
on the Website->Management page, near their name one could see with red font the name of the php  
file to be executed, for example for “Latest Links”  this is “latest_links.php”. 
The reason is that the code for these pages is rendered by the system, for example in the case of the  
Latest Links page, it's generated by the file /extensions/latest_links.php (which is the jobseekers sign  
up form), so the php code for it can't be modified with the WYSIWYG editor. 

The page can be modified by editing directly the file for it or if only some texts need to be changed,  
this may be done by modifying the language file (/include/texts_en.php for English). 

5.3. Website navigation menu 

To give maximum flexibility to modify the style of the front site menu, the administration panel provides  
also an option to edit the menu item template from the Website → Navigation Menu page in the  



administration panel.

In this template [LINK_TEXT] will be replaced by the text of the link (page name) as set by the  
administrator on the Website → Management page and [LINK_HREF] with the link to the page  
(generated by the script). 

5.4. Custom server side forms 

The custom server side forms functionality is a  feature allowing the administrator to create and  
publish on the front site forms (such as contact forms) with custom fields defined by the administrator.  
Adding a new custom server side form can be done on 2 steps - the first one is to enter the form name  
and a brief description and the second one is to add the form fields. For every field the administrator  
should specify its name, type, the text displayed near it, its size and if it's an obligatory field (available  
only for some of the fields) and the message which will show up if the user leaves empty an obligatory  
field.  
The new forms can be added from the Website → Manage the forms page and then clicking on the  
New Form at the top.



while the existing forms can be managed from the Tools → Manage the forms page in the admin  
panel.

The forms can be deleted, modified, copied (in order to copy forms on different pages on the front site)  
and also their settings can be modified. 

The settings that can be modified are: 
–  the form name (the name can be  

used for identification of the form,  
by default it doesn't show up on the  
website) 

–  the form description 
–  the text, which will show up on the  

submit button (like “Send” or  
“Enviar” etc.) 

–  message displayed after the user  
has successfully submitted the form 

–  and also the email to which the  



forms data will be sent, the administrator can fill in this field his preferred email address to  
which the data sent by the users will be forwarded (it will be also available in the admin panel  
on the Tools → Posted Data page)

5.5. Languages and language files 

The language files contain the text and words shown on the user interface. For every language there  
is one language file located in the /include folder. 
The name and location of the language file is: /include/texts_[CODE OF THE LANGUAGE].php 
or for example /include/texts_en.php for English. The language file contains the different messages as  
PHP variables, for example: 

$M_HIDE_RECENT_SEARCHES="hide recent searches"; 
$M_CLEAR_ALL="clear all"; 
$M_SEE_ALL="see all"; 
$M_WEBSITE_HOME="Website Home";  
… 

Translating the language file consists of translating the messages enclosed in brackets to the right, for  
example for Spanish: 

$M_HIDE_RECENT_SEARCHES="ocultar búsquedas recientes"; 
$M_CLEAR_ALL="borrar todos"; 
$M_SEE_ALL="ver todos"; 
$M_WEBSITE_HOME = "Sitio Web - Inicio"; 

In order to add a new language on the website, it's necessary to add the translated file in the /include  
folder and also the administrator has to use the form on the Settings → Language Versions page and  
enter the name of the new language for example “Deutsch” and the code for the new language, for  
example “DE”.  
The language code shows up after in the page links and is also used to for the name of the language  
file (in this case the language file will be /include/texts_de.php) and it's important to be 2 characters  
(like EN, DE, PT, TR etc).



6. Front site templates management 

6.1. Templates overview 

A template for the front site represents a standard HTML code mixed with some special  
WebSiteAdmin tags (the compatibility with the WebSiteAdmin template system, makes possible the  
usage of templates and features from other products using it, as well as combining different scripts  
and software products to work on one website).  
Please find below a brief description of the template system and tags and check also 6.3. Custom  
HTML tags to see how you may create also your own custom tags with custom php files and code  
executed for them. 

By default the page is rendered, the special tags inserted in the template are replaced by the  
corresponding content - let's consider the following example with a simple template: 

<html> 
<head> 
<meta> 
<title><wsa title/></title> 
<meta name="description" content="<wsa description/>" /> 
<meta name="keywords" content="<wsa keywords/>" /> 
... 

When the page is rendered, for example the tag <wsa title/> will be replaced with the page title (in  
general the page titles can be set by the administrator from the Website → Management page), so  
<title><wsa title/></title> will become: 

<title>The page title will come here</title> 

Please note that presence of none of these tags is obligatory, so you could combine them as you wish  
in order to create the website and layout suiting the best your specific needs. Be aware also that  
WebSiteAdmin allows you to create your own tags (from the “Custom tags” in the back office) and set  
php files created by you to be executed and the generated content to be used in real time to replace  
the tag with it. 

Here are some most common tags used in the default templates of the different scripts based on  
WebSiteAdmin: 

<wsa title/> - Title of the web page  
<wsa description/> - Meta description of the web page  
<wsa keywords/> - Meta keywords of the web page  
<wsa menu/>- Main navigation menu of the website  
<wsa languages_menu/> - The languages menu of the website  
<wsa content/> - The main content of a page  
<wsa form/> - The custom server side forms for this page if there are any  
<wsa logins/> - The main log in form of the website 
<wsa quick_search/> - The quick search form on the front site 



<wsa news/> - The news (the administrator can manage them from the News page in the ADMIN) 
<wsa featured_ads/> - The block displaying the featured ads 
<wsa bottom_menu/> - The bottom menu displayed at the bottom of the site (it contains the same  
items as the main navigation menu) 

Please note that depending on the current product or script you are using, not all these tags may be  
available on it. 

To see your current template, the tags in it or modify it, please go to Templates in the administration  
panel. 

6.2. Adding new templates and modifying the existing ones 

In the PHP Classified Ads administration panel you may find the following pages related to the front  
site templates management: 

Templates → Select a Template

The page offers the possibility to the administrator to select a template which will be used for the front 
site between the currently available templates. Please note that in order to be able to select a template 
for a given website, you need to add first the template (if it doesn't still exist)

Templates → Add a New Template
This page can be used to add new templates to the website. The administrator can add the new 
template by directly pasting its HTML code.

Templates → Modify

On this page the administrator can see the available templates and modify a selected template. In 
order to select a template for modification, the administrator should click on the Modify icon and then a 
new text area having the full template code will appear.

6.3. Custom HTML tags 

The custom HTML tags provide a great way to expand the current functionality by creating your own  
php scripts to be executed and the content they output to be shown precisely in a selected position by  
the administrator. 
This can be for example a php script calendar_tag.php showing a custom calendar, which needs to be  
added at the top right corner of all pages of the website. 

Creating a new custom tag is simple - the first step is to upload the corresponding PHP file in the  
/extensions folder on your site.  
Please note the file names of php files, which will be used for tags should end with tag in their name –  
for example calendar_tag.php or news_tag.php etc. 
Then from the Extensions → Tags page in the administrator panel, fill the tag name (for example:  
calendar) and click on the Add button. This will create the tag - <wsa calendar/> in this example and it  
will appear on the Tags page. 



The tag should be defined from Extension → Tags and then inserted in the template or in the page  
content. When the page is rendered all the custom defined tags will be replaced by the content  
generated by the script you set.  
The Tags page shows the current tags with their name, html code, the file to be executed (with a drop  
down listing all the uploaded tag files in the /extensions folder and a small delete icon allowing to  
delete the tag). 

The final step when creating a new tag is to associate your tag with the php file you uploaded – this  
can be done by simply selecting the file from the File dropdown (“calendar_tag.php” in this example)  
and click on the Save button at the bottom of the page.

After doing this, you can start using the tag by inserting it in the front site template (from Templates →  
Modify page) at the position you prefer in the template.  

6.4. Adding Google AdSense advertisements or Google Analytics 

Very often the administrator may need to add external HTML code on website, it can be for example  
the HTML code for Google AdSense or other type of advertisements or Google Analytics code or a  
code provided by Google WebMaster Tools to verify the website. 

Such HTML codes need to be pasted in front site template, which can be done from the Templates →  
Modify page in the administration panel. On this page, it's necessary to click on the Modify icon – this  
will show the HTML code of the template and paste the piece of HTML code for the banners, Google  



Analytics or similar.

When adding a counter or other tracking code like Googl Analytics, usually the best it to place it at the  
end of the template, for example just before the closing </body> tag. 

For the advertisements the position will depend on what position exactly in the template (for example,  
top or bottom or to the right of the website pages etc.) the administrator would like to add them. 

If you experience any difficulties when doing this, please don't hesitate to contact us and our support  
team will try to assist you asap. 

7. Administration panel users and groups 

The administrator has the possibility to create additional user groups for the main administration panel,  
add users in them and assign their permissions. This can be done from “Users” in the administration  
panel.

This functionality can be used if for example there are multiple persons working on the website (for  
example person A validating the listings posted by the users, person B responsible for the design of  
the website and templates management, person C adding news on the website etc.) 

7.1. User groups 

The user groups make easier the permissions management for the users – instead of setting  



individually the permissions for every users, it can be be possible to create different user groups, add  
the users in them and manage the permissions per group. 
For example, it can be possible to create a group of users who will be responsible only for posting  
news on the website “NewsAdministrators” and won't have access to the other pages like the ones for  
validating the listings etc. 

To create a new user group, the only field the administrator has to fill is the group user name.

The page shows below also the list of the groups with their ID and a check box allowing to select one  
or many groups and delete them.

7.2. Adding new users 

To add a new user, it's necessary to click on the New User button at the top of the User Groups page  
or choose directly from the main start menu Users → New User. 

When adding a new user, it's necessary to select its Type or User Groups between the ones added by  
the administrator, enter his username, password, phone and email.

To see a list of the current users or modify their information, it's necessary to go to the Users List page  
(can be selected from the start menu Users → Users List or using the top buttons while in the Users  
category in the administration panel) 



7.2. Permissions management 

To set the permissions for the different user groups, it's necessary to go to the Users → User  
Permissions page in the administration panel. 
The page shows a list of all the pages available by default in the  administration panel and a check  
box for every box – to grant a permission for a selected page, it's necessary to check the box for it and  
when when ready, to click on the Save button at the bottom of the page.

This will save the permissions sets for the user group. 



An user, member of an user group, which has been granted access to only some pages in the  
administration panel will see just these pages in the menus when he logs in. 
 


